Unplanned outage

Incident Report for Envoke

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 18:24 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 18:01 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2025 - 17:55 EDT

Investigating

We are currently investigating this issue and will provide an update within 30 minutes.
Posted Mar 25, 2025 - 17:32 EDT
This incident affected: Envoke Application, Forms and APIs (Contacts API, Leads API, Send Email API).