A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2024 - 15:59 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 16, 2024 - 15:51 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2024 - 13:10 EDT
Investigating
Due to a block of several of our IP addresses many emails aren't being delivered to inboxes. The cause of the issue has been identified and a solution is in progress. At this time we recommend that you wait to send out emails until this issue is resolved. We will post updates here as we have more information.